package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?i)(?:[2-9AJKQT][hscd]){3}`)
var str = `something something Ah6d8c.txt
something Qd6h7s.txt
somethingAcKhJssomething.txt
7h6c8c something.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}