re = /(?i)(?:[2-9AJKQT][hscd]){3}/mi
str = 'something something Ah6d8c.txt
something Qd6h7s.txt
somethingAcKhJssomething.txt
7h6c8c something.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end