const regex = /(?i)(?:[2-9AJKQT][hscd]){3}/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?:[2-9AJKQT][hscd]){3}', 'gmi')
const str = `something something Ah6d8c.txt
something Qd6h7s.txt
somethingAcKhJssomething.txt
7h6c8c something.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}