# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:|(?<!^)\G)\K([^ ]*)\s+/$1/g;t' <<< "asdas as das.mp3"