import Foundation
let pattern = #"(?:|(?<!^)\G)\K([^ ]*)\s+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"asdas as das.mp3"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)