using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:|(?<!^)\G)\K([^ ]*)\s+";
string substitution = @"$1";
string input = @"asdas as das.mp3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}