use strict;
my $str = 'asdas as das.mp3';
my $regex = qr/(?:|(?<!^)\G)\K([^ ]*)\s+/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";