re = /(?:|(?<!^)\G)\K([^ ]*)\s+/
str = 'asdas as das.mp3'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result