# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=>)[^>]+(?=<)//g;t' <<< "<td colspan='2'><a>This is a Text in <b>Bold</b></a></td>"