import Foundation
let pattern = #"(?<=>)[^>]+(?=<)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<td colspan='2'><a>This is a Text in <b>Bold</b></a></td>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)