use strict;
my $str = '<td colspan=\'2\'><a>This is a Text in <b>Bold</b></a></td>';
my $regex = qr/(?<=>)[^>]+(?=<)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";