re = /(?<=>)[^>]+(?=<)/
str = '<td colspan=\'2\'><a>This is a Text in <b>Bold</b></a></td>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result