$re = '/(?<=>)[^>]+(?=<)/';
$str = '<td colspan=\'2\'><a>This is a Text in <b>Bold</b></a></td>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;