#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((\w+)(\[\d+\])*\.){2}(\w+)(\[\d+\])*$"
Local $sString = "aa[1].bb[2].cc.dd" & @CRLF & _
"aa[1].bb[2][3].cc" & @CRLF & _
"aa[1].bb[2][3].cc[1]" & @CRLF & _
"aa[1].bb[2][3].cc[2][12]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")