re = /^((\w+)(\[\d+\])*\.){2}(\w+)(\[\d+\])*$/m
str = 'aa[1].bb[2].cc.dd
aa[1].bb[2][3].cc
aa[1].bb[2][3].cc[1]
aa[1].bb[2][3].cc[2][12]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end