package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\w+)(\[\d+\])*\.){2}(\w+)(\[\d+\])*$`)
var str = `aa[1].bb[2].cc.dd
aa[1].bb[2][3].cc
aa[1].bb[2][3].cc[1]
aa[1].bb[2][3].cc[2][12]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}