$re = '/^((\w+)(\[\d+\])*\.){2}(\w+)(\[\d+\])*$/m';
$str = 'aa[1].bb[2].cc.dd
aa[1].bb[2][3].cc
aa[1].bb[2][3].cc[1]
aa[1].bb[2][3].cc[2][12]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);