using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\w+)(\[\d+\])*\.){2}(\w+)(\[\d+\])*$";
string input = @"aa[1].bb[2].cc.dd
aa[1].bb[2][3].cc
aa[1].bb[2][3].cc[1]
aa[1].bb[2][3].cc[2][12]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}