use strict;
my $str = 'aa[1].bb[2].cc.dd
aa[1].bb[2][3].cc
aa[1].bb[2][3].cc[1]
aa[1].bb[2][3].cc[2][12]';
my $regex = qr/^((\w+)(\[\d+\])*\.){2}(\w+)(\[\d+\])*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}