#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xmi)^(a|b|start)(\d*%)?(\d*(s|ms))?"
Local $sString = "b50%25ms" & @CRLF & _
"a500ms50ms" & @CRLF & _
"a500msb50ms" & @CRLF & _
"start200s" & @CRLF & _
"" & @CRLF & _
"start20%12ms" & @CRLF & _
"a600msb200ms" & @CRLF & _
"" & @CRLF & _
"astart" & @CRLF & _
"a" & @CRLF & _
"b" & @CRLF & _
"" & @CRLF & _
"Invalid" & @CRLF & _
"a500ms50%" & @CRLF & _
"ams500b #ms does not have duration" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")