import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(a|b|start)(\\d*%)?(\\d*(s|ms))?";
final String string = "b50%25ms\n"
+ "a500ms50ms\n"
+ "a500msb50ms\n"
+ "start200s\n\n"
+ "start20%12ms\n"
+ "a600msb200ms\n\n"
+ "astart\n"
+ "a\n"
+ "b\n\n"
+ "Invalid\n"
+ "a500ms50%\n"
+ "ams500b #ms does not have duration\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}