using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(a|b|start)(\d*%)?(\d*(s|ms))?";
string input = @"b50%25ms
a500ms50ms
a500msb50ms
start200s
start20%12ms
a600msb200ms
astart
a
b
Invalid
a500ms50%
ams500b #ms does not have duration
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}