re = /^(a|b|start)(\d*%)?(\d*(s|ms))?/xmi
str = 'b50%25ms
a500ms50ms
a500msb50ms
start200s
start20%12ms
a600msb200ms
astart
a
b
Invalid
a500ms50%
ams500b #ms does not have duration
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end