const regex = /^(a|b|start)(\d*%)?(\d*(s|ms))?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(a|b|start)(\\d*%)?(\\d*(s|ms))?', 'gmi')
const str = `b50%25ms
a500ms50ms
a500msb50ms
start200s
start20%12ms
a600msb200ms
astart
a
b
Invalid
a500ms50%
ams500b #ms does not have duration
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}