# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^(a|b|start)(\d*%)?(\d*(s|ms))?
"""
test_str = ("b50%25ms\n"
"a500ms50ms\n"
"a500msb50ms\n"
"start200s\n\n"
"start20%12ms\n"
"a600msb200ms\n\n"
"astart\n"
"a\n"
"b\n\n"
"Invalid\n"
"a500ms50%\n"
"ams500b #ms does not have duration\n")
matches = re.finditer(regex, test_str, re.VERBOSE | re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.