#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?:(?:qu)?)*[^aeiou]*)(.*)"
Local $sString = "quick"
Local $sSubst = "\2\1ay"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)