using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:(?:qu)?)*[^aeiou]*)(.*)";
string substitution = @"\2\1ay";
string input = @"quick";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}