$re = '/((?:(?:qu)?)*[^aeiou]*)(.*)/';
$str = 'quick';
$subst = "\2\1ay";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;