use strict;
my $str = 'quick';
my $regex = qr/((?:(?:qu)?)*[^aeiou]*)(.*)/p;
my $subst = '\\2\\1ay';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";