// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:(?:qu)?)*[^aeiou]*)(.*)").unwrap();
let string = "quick";
let substitution = "\\2\\1ay";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}