const regex = /((?:(?:qu)?)*[^aeiou]*)(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:(?:qu)?)*[^aeiou]*)(.*)', '')
const str = `quick`;
const subst = `\2\1ay`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);