re = /.*n.?t?.*reply.*@(.+\.)+.+/
str = 'dontreply@a.b.com
noreply@a.b3.com
donotreply@a.b
no-reply@a.b
pleasedonotreply@a.b
do-not-replyplease@a.b
dontreplyplease@a.b'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end