const regex = /.*?(?<=CREATED ON )([^>]+)>.*/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?(?<=CREATED ON )([^>]+)>.*', 's')
const str = `</BODY></HTML><FILE CREATED ON 0:32:33 Feb 24, 2009>{several empty lines before the end of document}`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);