use strict;
my $str = '</BODY></HTML><FILE CREATED ON 0:32:33 Feb 24, 2009>{several empty lines before the end of document}';
my $regex = qr/.*?(?<=CREATED ON )([^>]+)>.*/sp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";