re = /.*?(?<=CREATED ON )([^>]+)>.*/
str = '</BODY></HTML><FILE CREATED ON 0:32:33 Feb 24, 2009>{several empty lines before the end of document}'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result