import re
regex = re.compile(r".*?(?<=CREATED ON )([^>]+)>.*", flags=re.DOTALL)
test_str = "</BODY></HTML><FILE CREATED ON 0:32:33 Feb 24, 2009>{several empty lines before the end of document}"
subst = "$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)