#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+\s*=[\d\+\-\*\/\s]*\.\d[\d\+\-\*\/\s]*;"
Local $sString = "123 = +/- + .1-**- +;" & @CRLF & _
"valor_1 = func(2.5);" & @CRLF & _
"valor = 1e-2;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")