using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+\s*=[\d\+\-\*\/\s]*\.\d[\d\+\-\*\/\s]*;";
string input = @"123 = +/- + .1-**- +;
valor_1 = func(2.5);
valor = 1e-2;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}