// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w+\s*=[\d\+\-\*\/\s]*\.\d[\d\+\-\*\/\s]*;").unwrap();
let string = "123 = +/- + .1-**- +;
valor_1 = func(2.5);
valor = 1e-2;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}