package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+\s*=[\d\+\-\*\/\s]*\.\d[\d\+\-\*\/\s]*;`)
var str = `123 = +/- + .1-**- +;
valor_1 = func(2.5);
valor = 1e-2;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}