import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+\\s*=[\\d\\+\\-\\*\\/\\s]*\\.\\d[\\d\\+\\-\\*\\/\\s]*;";
final String string = "123 = +/- + .1-**- +;\n"
+ "valor_1 = func(2.5);\n"
+ "valor = 1e-2;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}