$re = '/\w+\s*=[\d\+\-\*\/\s]*\.\d[\d\+\-\*\/\s]*;/m';
$str = '123 = +/- + .1-**- +;
valor_1 = func(2.5);
valor = 1e-2;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);