# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\[|')([^\]']+\(Delete\)[^\]']+)(?:'|\])//g;t' <<< "[manikv (Delete) 4916258]
'morl20 (Delete) 180977'"