const regex = /(?:\[|')([^\]']+\(Delete\)[^\]']+)(?:'|\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\[|\')([^\\]\']+\\(Delete\\)[^\\]\']+)(?:\'|\\])', 'g')
const str = `[manikv (Delete) 4916258]
'morl20 (Delete) 180977'`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);