// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\[|')([^\]']+\(Delete\)[^\]']+)(?:'|\])").unwrap();
let string = "[manikv (Delete) 4916258]
'morl20 (Delete) 180977'";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}