using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[|')([^\]']+\(Delete\)[^\]']+)(?:'|\])";
string substitution = @"";
string input = @"[manikv (Delete) 4916258]
'morl20 (Delete) 180977'";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}