package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\[|')([^\]']+\(Delete\)[^\]']+)(?:'|\])`)
var str = `[manikv (Delete) 4916258]
'morl20 (Delete) 180977'`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}