use strict;
my $str = '[manikv (Delete) 4916258]
\'morl20 (Delete) 180977\'';
my $regex = qr/(?:\[|')([^\]']+\(Delete\)[^\]']+)(?:'|\])/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";