using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=,)|^)(?=(""(?:[^""]+(?:"")*)*""|[^"",]*))\1,";
string substitution = @"\1;";
string input = @"""3,14"",""1,000,000"",hippo,""cat,dog,frog"",plain text,""2,25""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}