import re
regex = re.compile(r"(?:(?<=,)|^)(?=(\"(?:[^\"]+(?:\"\")*)*\"|[^\",]*))\1,")
test_str = "\"3,14\",\"1,000,000\",hippo,\"cat,dog,frog\",plain text,\"2,25\""
subst = "\\1;"
result = regex.sub(subst, test_str)
if result:
print(result)